GROFF_MDOC(7) | Miscellaneous Information Manual | GROFF_MDOC(7) |
groff -mdoc file ... |
Throughout the UNIX manual pages, a manual entry is simply referred to as a man page, regardless of actual length and without sexist intention.
.
' (dot character) at the beginning of a line followed by the two-character (or three-character) name for the macro. There can be space or tab characters between the dot and the macro name. Arguments may follow the macro separated by spaces (but no tabs). It is the dot character at the beginning of the line which causes GNU troff(1) to interpret the next two (or more) characters as a macro name. A single starting dot followed by nothing is ignored. To place a ‘.
' (dot character) at the beginning of an input line in some context other than a macro invocation, precede the ‘.
' (dot) with the ‘\&
' escape sequence which translates literally to a zero-width space, and is never displayed in the output.In general, GNU troff(1) macros accept an unlimited number of arguments (contrary to other versions of troff which can't handle more than nine arguments). In limited cases, arguments may be continued or extended on the next line (See Extended Arguments below). Almost all macros handle quoted arguments (see Passing Space Characters in an Argument below).
Most of the -mdoc general text domain and manual domain macros are special in that their argument lists are parsed for callable macro names. This means an argument on the argument list which matches a general text or manual domain macro name (and which is defined to be callable) will be executed or called when it is processed. In this case the argument, although the name of a macro, is not preceded by a ‘.
' (dot). This makes it possible to nest macros; for example the option macro, ‘.Op
', may call the flag and argument macros, ‘Fl
' and ‘Ar
', to specify an optional flag with an argument:
.Op Fl s Ar bytes
'
To prevent a string from being interpreted as a macro name, precede the string with the escape sequence ‘\&
':
.Op \&Fl s \&Ar bytes
'
Here the strings ‘Fl
' and ‘Ar
' are not interpreted as macros. Macros whose argument lists are parsed for callable arguments are referred to as parsed and macros which may be called from an argument list are referred to as callable throughout this document. This is a technical faux pas as almost all of the macros in -mdoc are parsed, but as it was cumbersome to constantly refer to macros as being callable and being able to call other macros, the term parsed has been used.
In the following, we call an -mdoc macro which starts a line (with a leading dot) a command if this distinction is necessary.
.Fn
' expects the first argument to be the name of a function and any remaining arguments to be function parameters. As ANSI C stipulates the declaration of function parameters in the parenthesized parameter list, each parameter is guaranteed to be at minimum a two word string. For example, int foo.
There are two possible ways to pass an argument which contains an embedded space. One way of passing a string containing blank spaces is to use the hard or unpaddable space character ‘\
', that is, a blank space preceded by the escape character ‘\
'. This method may be used with any macro but has the side effect of interfering with the adjustment of text over the length of a line. Troff sees the hard space as if it were any other printable character and cannot split the string into blank or newline separated pieces as one would expect. This method is useful for strings which are not expected to overlap a line boundary. An alternative is to use ‘\~
', a paddable (i.e. stretchable), unbreakable space (this is a GNU troff(1) extension). The second method is to enclose the string with double quotes.
For example:
.Fn fetch char\ *str
'.Fn fetch "char *str"
'
If the ‘\
' before the space in the first example or double quotes in the second example were omitted, ‘.Fn
' would see three arguments, and the result would be:
fetch(char, *str)
\&
' escape character. For example, ‘string\ \&
'.\n
' are handled by replacing the ‘\
' with ‘\e
' (e.g. ‘\en
') to preserve the backslash..sp
' instead. (Well, it is even better to use -mdoc macros to avoid the usage of low-level commands.)Leading spaces will cause a break and are output directly. Avoid this behaviour if possible. Similarly, do not use more than one space character between words in an ordinary text line; contrary to other text formatters, they are not replaced with a single space.
You can't pass ‘"
' directly as an argument. Use ‘\*[q]
' (or ‘\*q
') instead.
By default, troff(1) inserts two space characters after a punctuation mark closing a sentence; characters like ‘)
' or ‘'
' are treated transparently, not influencing the sentence-ending behaviour. To change this, insert ‘\&
' before or after the dot:
The .Ql . character. .Pp The .Ql \&. character. .Pp .No test . test .Pp .No test. test
gives
'. character
The ‘.
' character.
test. test
test. test
As can be seen in the first and third line, -mdoc handles punctuation characters specially in macro arguments. This will be explained in section General Syntax below. In the same way, you have to protect trailing full stops of abbreviations with a trailing zero-width space: ‘e.g.\&
'.
A comment in the source file of a man page can be either started with ‘.\"
' on a single line, ‘\"
' after some input, or ‘\#
' anywhere (the latter is a GNU troff(1) extension); the rest of such a line is ignored.
.\" The following commands are required for all man pages. .Dd Month day, year .Dt DOCUMENT_TITLE [section number] [architecture/volume] .Os [OPERATING_SYSTEM] [version/release] .Sh NAME .Nm name .Nd one line description of name .\" This next command is for sections 2 and 3 only. .\" .Sh LIBRARY .Sh SYNOPSIS .Sh DESCRIPTION .\" The following commands should be uncommented and .\" used where appropriate. .\" .Sh IMPLEMENTATION NOTES .\" This next command is for sections 2, 3 and 9 function .\" return values only. .\" .Sh RETURN VALUES .\" This next command is for sections 1, 6, 7 and 8 only. .\" .Sh ENVIRONMENT .\" .Sh FILES .\" .Sh EXAMPLES .\" This next command is for sections 1, 6, 7, 8 and 9 only .\" (command return values (to shell) and .\" fprintf/stderr type diagnostics). .\" .Sh DIAGNOSTICS .\" .Sh COMPATIBILITY .\" This next command is for sections 2, 3 and 9 error .\" and signal handling only. .\" .Sh ERRORS .\" .Sh SEE ALSO .\" .Sh STANDARDS .\" .Sh HISTORY .\" .Sh AUTHORS .\" .Sh BUGS
The first items in the template are the commands ‘.Dd
', ‘.Dt
', and ‘.Os
'; the document date, the man page title (in upper case) along with the section of the manual the page belongs in, and the operating system the man page or subject source is developed or modified for. These commands identify the page and are discussed below in TITLE MACROS.
The remaining items in the template are section headers (.Sh
); of which NAME, SYNOPSIS, and DESCRIPTION are mandatory. The headers are discussed in PAGE STRUCTURE DOMAIN, after presentation of MANUAL DOMAIN. Several content macros are used to demonstrate page layout macros; reading about content macros before page layout macros is recommended.
|
'. If there are alternative values for a mandatory parameter, braces are used (together with ‘|
') to enclose the value set. Meta-variables are specified within angles.Example:
.Xx
<foo> {bar1 | bar2} [-test1 [-test2 | -test3]] ...Except stated explicitly, all macros are parsed and callable.
Note that a macro takes effect up to the next nested macro. For example, ‘.Ic foo Aq bar
' doesn't produce ‘foo <bar>' but ‘foo <bar>'. Consequently, a warning message is emitted for most commands if the first argument is a macro itself since it cancels the effect of the calling command completely. Another consequence is that quoting macros never insert literal quotes; ‘foo <bar>' has been produced by ‘.Ic "foo <bar>"
'.
Most macros have a default width value which can be used to specify a label width (-width) or offset (-offset) for the ‘.Bl
' and ‘.Bd
' macros. It is recommended not to use this rather obscure feature to avoid dependencies on local modifications of the -mdoc package.
.Dt
[<document title>] [<section number>] [<volume>]unass
', ‘draft
', or ‘paper
'. If it is specified, and no volume name is given, a default volume name is used.Under, the following sections are defined:
1 |
|
2 |
|
3 |
|
4 |
|
5 |
|
6 |
|
7 |
|
8 |
|
9 |
A volume name may be arbitrary or one of the following:
USD |
|
PS1 |
|
AMD |
|
SMM |
|
URM |
|
PRM |
|
KM |
|
IND |
|
LOCAL |
|
CON |
For compatibility, ‘MMI
' can be used for ‘IND
', and ‘LOC
' for ‘LOCAL
'. Values from the previous table will specify a new volume name. If the third parameter is a keyword designating a computer architecture, its value is prepended to the default volume name as specified by the second parameter. By default, the following architecture keywords are defined:
If the section number is neither a numeric expression in the range 1 to 9 nor one of the above described keywords, the third parameter is used verbatim as the volume name.
In the following examples, the left (which is identical to the right) and the middle part of the manual page header strings are shown. Note how ‘\&
' prevents the digit 7 from being a valid numeric expression.
.Dt FOO 7
FOO(7)
' ‘
'.Dt FOO 7 bar
FOO(7)
' ‘
'.Dt FOO \&7 bar
FOO(7)
' ‘bar
'.Dt FOO 2 i386
FOO(2)
' ‘/
'.Dt FOO "" bar
FOO
' ‘bar
'
Local, OS-specific additions might be found in the file mdoc.local; look for strings named ‘volume-ds-XXX
' (for the former type) and ‘volume-as-XXX
' (for the latter type); ‘XXX
' then denotes the keyword to be used with the ‘.Dt
' macro.
This macro is neither callable nor parsed.
.Os
[<operating system>] [<release>].Dt
', local additions might be defined in mdoc.local; look for strings named ‘operating-system-XXX-YYY
', where ‘XXX
' is the acronym for the operating system and ‘YYY
' the release ID.For ATT, an unknown second parameter will be replaced with the string UNIX; for the other predefined acronyms it will be ignored and a warning message emitted. Unrecognized arguments are displayed as given in the page footer. For instance, a typical footer might be:
.Os BSD 4.3
giving ‘4.3 Berkeley Distribution
', or for a locally produced set
.Os CS Department
which will produce ‘CS Department
'.
If the ‘.Os
' macro is not present, the bottom left corner of the manual page will be ugly.
This macro is neither callable nor parsed.
.Dd
[<month> <day>, <year>]Dd
' has no arguments, ‘Epoch
' is used for the date string. If it has exactly three arguments, they are concatenated, separated with unbreakable space:
.Dd January 25, 2001
The month's name shall not be abbreviated.
With any other number of arguments, the current date is used, ignoring the parameters.
This macro is neither callable nor parsed.
In the first case, troff(1) macros are themselves a type of command; the general syntax for a troff command is:
.Xx argument1 argument2 ...
‘.Xx
' is a macro command, and anything following it are arguments to be processed. In the second case, the description of a UNIX command using the content macros is a bit more involved; a typical SYNOPSIS command line might be displayed as:
Here, filter is the command name and the bracketed string -flag is a flag argument designated as optional by the option brackets. In -mdoc terms, <infile> and <outfile> are called meta arguments; in this example, the user has to replace the meta expressions given in angle brackets with real file names. Note that in this document meta arguments are used to describe -mdoc commands; in most man pages, meta variables are not specifically written with angle brackets. The macros which formatted the above example:
.Nm filter .Op Fl flag .Ao Ar infile Ac Ao Ar outfile Ac
In the third case, discussion of commands and command syntax includes both examples above, but may add more detail. The arguments <infile> and <outfile> from the example above might be referred to as operands or file arguments. Some command line argument lists are quite long:
Here one might talk about the command make and qualify the argument, makefile, as an argument to the flag, -f, or discuss the optional file operand target. In the verbal context, such detail can prevent confusion, however the -mdoc package does not have a macro for an argument to a flag. Instead the ‘Ar
' argument macro is used for an operand or file argument like target as well as an argument to a flag like variable. The make command line was produced from:
.Nm make .Op Fl eiknqrstv .Op Fl D Ar variable .Op Fl d Ar flags .Op Fl f Ar makefile .Op Fl I Ar directory .Op Fl j Ar max_jobs .Op Ar variable Ns = Ns Ar value .Bk .Op Ar target ... .Ek
The ‘.Bk
' and ‘.Ek
' macros are explained in Keeps.
.Ar
', ‘.Fl
', ‘.Nm
', and ‘.Pa
' differ only when called without arguments; and ‘.Fn
' and ‘.Xr
' impose an order on their argument lists. All content macros are capable of recognizing and properly handling punctuation, provided each punctuation character is separated by a leading space. If a command is given:
.Ar sptr, ptr),
The result is:
sptr, ptr),
The punctuation is not recognized and all is output in the font used by ‘.Ar
'. If the punctuation is separated by a leading white space:
.Ar sptr , ptr ) ,
The result is:
sptr, ptr),
The punctuation is now recognized and output in the default font distinguishing it from the argument strings. To remove the special meaning from a punctuation character escape it with ‘\&
'.
The following punctuation characters are recognized by -mdoc:
. |
, |
: |
; |
( |
) |
[ |
] |
? |
! |
Troff is limited as a macro language, and has difficulty when presented with a string containing a member of the mathematical, logical or quotation set:
{+,-,/,*,%,<,>,<=,>=,=,==,&,`,',"}
The problem is that troff may assume it is supposed to actually perform the operation or evaluation suggested by the characters. To prevent the accidental evaluation of these characters, escape them with ‘\&
'. Typical syntax is shown in the first content macro displayed below, ‘.Ad
'.
Usage: .Ad <address> ...
.Ad addr1
.Ad addr1 .
.Ad addr1 , file2
.Ad f1 , f2 , f3 :
.Ad addr ) ) ,
The default width is 12n.
.An
' macro is used to specify the name of the author of the item being documented, or the name of the author of the actual manual page.
Usage: .An <author name> ...
.An "Joe Author"
.An "Joe Author" ,
.An "Joe Author" Aq nobody@FreeBSD.org
.An "Joe Author" ) ) ,
The default width is 12n.
In the AUTHORS section, the ‘.An
' command causes a line break allowing each new name to appear on its own line. If this is not desirable,
.An -nosplit
call will turn this off. To turn splitting back on, write
.An -split
.Ar
argument macro may be used whenever an argument is referenced. If called without arguments, the ‘file ...' string is output.
Usage: .Ar [<argument>] ...
.Ar
.Ar file1
.Ar file1 .
.Ar file1 file2
.Ar f1 f2 f3 :
.Ar file ) ) ,
The default width is 12n.
.Cd
' macro is used to demonstrate a config(1) declaration for a device interface in a section four manual.
Usage: .Cd <argument> ...
.Cd "device le0 at scode?"
In the SYNOPSIS section a ‘.Cd
' command causes a line break before and after its arguments are printed.
The default width is 12n.
.Fl
' (flag) command with the exception that the ‘.Cm
' macro does not assert a dash in front of every argument. Traditionally flags are marked by the preceding dash, however, some commands or subsets of commands do not use them. Command modifiers may also be specified in conjunction with interactive commands such as editor commands. See Flags.The default width is 10n.
.Dv
'.
Usage: .Dv <defined variable> ...
.Dv MAXHOSTNAMELEN
.Dv TIOCGPGRP )
The default width is 12n.
.Er
' errno macro specifies the error return value for section 2, 3, and 9 library routines. The second example below shows ‘.Er
' used with the ‘.Bq
' general text domain macro, as it would be used in a section two manual page.
Usage: .Er <errno type> ...
.Er ENOENT
.Er ENOENT ) ;
.Bq Er ENOTDIR
The default width is 17n.
.Ev
' macro specifies an environment variable.
Usage: .Ev <argument> ...
.Ev DISPLAY
.Ev PATH .
.Ev PRINTER ) ) ,
The default width is 15n.
.Fl
' macro handles command line flags. It prepends a dash, ‘-
', to the flag. For interactive command flags, which are not prepended with a dash, the ‘.Cm
' (command modifier) macro is identical, but without the dash.
Usage: .Fl <argument> ...
.Fl
.Fl cfv
.Fl cfv .
.Cm cfv .
.Fl s v t
.Fl - ,
.Fl xyz ) ,
.Fl |
The ‘.Fl
' macro without any arguments results in a dash representing stdin/stdout. Note that giving ‘.Fl
' a single dash will result in two dashes.
The default width is 12n.
.Fd
' macro is used in the SYNOPSIS section with section two or three functions. It is neither callable nor parsed.
Usage: .Fd <argument> ...
.Fd "#include <sys/types.h>"
In the SYNOPSIS section a ‘.Fd
' command causes a line break if a function has already been presented and a break has not occurred. This leaves a nice vertical space in between the previous function call and the declaration for the next function.
The ‘.In
' macro, while in the SYNOPSIS section, represents the #include
statement, and is the short form of the above example. It specifies the C header file as being included in a C program. It also causes a line break.
While not in the SYNOPSIS section, it represents the header file enclosed in angle brackets.
Usage: .In <header file>
Usage: .Ft <type> ...
.Ft struct stat
.Fn
' macro is modeled on ANSI C conventions.
Usage: .Fn <function> [<parameter>] ...
.Fn getchar
.Fn strlen ) ,
.Fn align "char *ptr" ,
Note that any call to another macro signals the end of the ‘.Fn
' call (it will insert a closing parenthesis at that point).
For functions with many parameters (which is rare), the macros ‘.Fo
' (function open) and ‘.Fc
' (function close) may be used with ‘.Fa
' (function argument).
Example:
.Ft int .Fo res_mkquery .Fa "int op" .Fa "char *dname" .Fa "int class" .Fa "int type" .Fa "char *data" .Fa "int datalen" .Fa "struct rrec *newrr" .Fa "char *buf" .Fa "int buflen" .Fc
Produces:
In the SYNOPSIS section, the function will always begin at the beginning of line. If there is more than one function presented in the SYNOPSIS section and a function type has not been given, a line break will occur, leaving a nice vertical space between the current function name and the one prior.
The default width values of ‘.Fn
' and ‘.Fo
' are 12n and 16n, respectively.
.Fa
' macro is used to refer to function arguments (parameters) outside of the SYNOPSIS section of the manual or inside the SYNOPSIS section if the enclosure macros ‘.Fo
' and ‘.Fc
' instead of ‘.Fn
' are used. ‘.Fa
' may also be used to refer to structure members.
Usage: .Fa <function argument> ...
.Fa d_namlen ) ) ,
.Fa iov_len
The default width is 12n.
.Rv
' macro generates text for use in the RETURN VALUES section.
Usage: .Rv [-std] [<function> ...]
For example, ‘.Rv -std atexit
' produces:
The -std option is valid only for manual page sections 2 and 3. Currently, this macro does nothing if used without the -std flag.
.Ex
' macro generates text for use in the DIAGNOSTICS section.
Usage: .Ex [-std] [<utility> ...]
For example, ‘.Ex -std cat
' produces:
The -std option is valid only for manual page sections 1, 6 and 8. Currently, this macro does nothing if used without the -std flag.
.Ic
' macro designates an interactive or internal command.
Usage: .Ic <argument> ...
.Ic :wq
.Ic "do while {...}"
.Ic setenv , unsetenv
The default width is 12n.
.Lb
' macro is used to specify the library where a particular function is compiled in.
Usage: .Lb <argument> ...
Available arguments to ‘.Lb
' and their results are:
libarm
libarm32
libc
libcdk
libcompat
libcrypt
libcurses
libedit
libevent
libform
libi386
libintl
libipsec
libisns
libkvm
libm
libm68k
libmagic
libmenu
libossaudio
libpam
libpcap
libpci
libpmc
libposix
libpthread
libresolv
librt
libsaslc
libtermcap
libusbhid
libutil
libx86_64
libz
Local, OS-specific additions might be found in the file mdoc.local; look for strings named ‘str-Lb-XXX
'. ‘XXX
' then denotes the keyword to be used with the ‘.Lb
' macro.
In the LIBRARY section an ‘.Lb
' command causes a line break before and after its arguments are printed.
.Li
' literal macro may be used for special characters, variable constants, etc. -- anything which should be displayed as it would be typed.
Usage: .Li <argument> ...
.Li \en
\n
.Li M1 M2 M3 ;
M1 M2 M3
;.Li cntrl-D ) ,
cntrl-D
),.Li 1024 ...
1024 ...
The default width is 16n.
.Nm
' macro is used for the document title or subject name. It has the peculiarity of remembering the first argument it was called with, which should always be the subject name of the page. When called without arguments, ‘.Nm
' regurgitates this initial name for the sole purpose of making less work for the author. Note: A section two or three document function name is addressed with the ‘.Nm
' in the NAME section, and with ‘.Fn
' in the SYNOPSIS and remaining sections. For interactive commands, such as the ‘while
' command keyword in csh(1), the ‘.Ic
' macro should be used. While ‘.Ic
' is nearly identical to ‘.Nm
', it can not recall the first argument it was invoked with.
Usage: .Nm [<argument>] ...
.Nm groff_mdoc
.Nm \-mdoc
.Nm foo ) ) ,
.Nm :
The default width is 10n.
.Op
' macro places option brackets around any remaining arguments on the command line, and places any trailing punctuation outside the brackets. The macros ‘.Oo
' and ‘.Oc
' (which produce an opening and a closing option bracket respectively) may be used across one or more lines or to specify the exact position of the closing parenthesis.
Usage: .Op [<option>] ...
.Op
.Op Fl k
.Op Fl k ) .
.Op Fl k Ar kookfile
.Op Fl k Ar kookfile ,
.Op Ar objfil Op Ar corfil
.Op Fl c Ar objfil Op Ar corfil ,
.Op word1 word2
.Li .Op Oo Ao option Ac Oc ...
.Op
[<option>] ...
Here a typical example of the ‘.Oo
' and ‘.Oc
' macros:
.Oo .Op Fl k Ar kilobytes .Op Fl i Ar interval .Op Fl c Ar count .Oc
Produces:
The default width values of ‘.Op
' and ‘.Oo
' are 14n and 10n, respectively.
.Pa
' macro formats path or file names. If called without arguments, the ‘~' string is output, which represents the current user's home directory.
Usage: .Pa [<pathname>] ...
.Pa
.Pa /usr/share
.Pa /tmp/fooXXXXX ) .
The default width is 32n.
.St
' macro replaces standard abbreviations with their formal names.
Usage: .St <abbreviation> ...
Available pairs for “Abbreviation/Formal Name” are:
ANSI/ISO C
-ansiC
-ansiC-89
-isoC
-isoC-90
-isoC-99
POSIX Part 1: System API
-iso9945-1-90
-iso9945-1-96
-p1003.1
-p1003.1-88
-p1003.1-90
-p1003.1-96
-p1003.1b-93
-p1003.1c-95
-p1003.1g-2000
-p1003.1i-95
-p1003.1-2001
-p1003.1-2004
-p1003.1-2008
POSIX Part 2: Shell and Utilities
-iso9945-2-93
-p1003.2
-p1003.2-92
-p1003.2a-92
X/Open
-susv2
-svid4
-xbd5
-xcu5
-xcurses4.2
-xns5
-xns5.2
-xpg3
-xpg4
-xpg4.2
-xsh5
Miscellaneous
-ieee754
-iso8802-3
.Vt
' macro may be used whenever a type is referenced. In the SYNOPSIS section, it causes a line break (useful for old style variable declarations).
Usage: .Vt <type> ...
.Vt extern char *optarg ;
.Vt FILE *
Usage: .Va <variable> ...
.Va count
.Va settimer ,
.Va "int *prt" ) :
.Va "char s" ] ) ) ,
The default width is 12n.
.Xr
' macro expects the first argument to be a manual page name. The optional second argument, if a string (defining the manual section), is put into parentheses.
Usage: .Xr <man page name> [<section>] ...
The default width is 10n.
Usage: .At [<version>] ...
.At
.At v6 .
The following values for <version> are possible:
32v, v1, v2, v3, v4, v5, v6, v7, V, V.1, V.2, V.3, V.4
Usage: .Bx {-alpha | -beta | -devel} ...
.Bx [<version> [<release>]] ...
.Bx
.Bx 4.3 .
.Bx -devel
<version> will be prepended to the string ‘BSD'. The following values for <release> are possible:
Reno, reno, Tahoe, tahoe, Lite, lite, Lite2, lite2
Usage: .Nx [<version>] ...
.Nx
.Nx 1.4 .
For possible values of <version> see the description of the ‘.Os
' command above in section TITLE MACROS.
Usage: .Fx [<version>] ...
.Fx
.Fx 2.2 .
For possible values of <version> see the description of the ‘.Os
' command above in section TITLE MACROS.
Usage: .Ox [<version>] ...
.Ox 1.0
Usage: .Bsx [<version>] ...
.Bsx 1.0
Usage: .Ux ...
.Ux
.Em
' macro. The usual font for emphasis is italic.
Usage: .Em <argument> ...
.Em does not
.Em exceed 1024 .
.Em vide infra ) ) ,
The default width is 10n.
.Bf
' font mode must be ended with the ‘.Ef
' macro (the latter takes no arguments). Font modes may be nested within other font modes.
‘.Bf
' has the following syntax:
.Bf <font mode>
<font mode> must be one of the following three types:
.Em
' macro was used for the entire block of text..Li
' macro was used for the entire block of text..Sy
' macro was used for the entire block of text.Both macros are neither callable nor parsed.
q
' to give a hint of quoting, but there are a few irregularities. For each enclosure macro there is also a pair of open and close macros which end in small letters ‘o
' and ‘c
' respectively.
Quote | Open | Close | Function | Result |
.Aq | .Ao | .Ac | Angle Bracket Enclosure | <string> |
.Bq | .Bo | .Bc | Bracket Enclosure | [string] |
.Brq | .Bro | .Brc | Brace Enclosure | {string} |
.Dq | .Do | .Dc | Double Quote | “string” |
.Eq | .Eo | .Ec | Enclose String (in XX) | XXstringXX |
.Pq | .Po | .Pc | Parenthesis Enclosure | (string) |
.Ql | Quoted Literal |
‘string' or string |
||
.Qo | .Qc | Straight Double Quote | “string” | |
.Sq | .So | .Sc | Single Quote | ‘string' |
All macros ending with ‘q' and ‘o' have a default width value of 12n.
.Eo
, .Ec
.Es
, .En
.Es
' takes the first and second parameter as the left and right enclosure string, which are then used to enclose the arguments of ‘.En
'. The default width value is 12n for both macros..Eq
.Ql
The default width is 16n.
.Pf
.Pf ( Fa name2
The default width is 12n.
The ‘.Ns
' macro (see below) performs the analogous suffix function.
.Ap
.Ap
' macro inserts an apostrophe and exits any special text modes, continuing in ‘.No
' mode.Examples of quoting:
.Aq
.Aq Pa ctype.h ) ,
.Bq
.Bq Em Greek , French .
.Dq
.Dq string abc .
.Dq ́^[A-Z]́
.Ql man mdoc
man mdoc
'.Qq
.Qq string ) ,
.Qq string Ns ),
.Sq
.Sq string
.Em or Ap ing
For a good example of nested enclosure macros, see the ‘.Op
' option macro. It was created from the same underlying enclosure macros as those presented in the list above. The ‘.Xo
' and ‘.Xc
' extended argument list macros are discussed below.
.No
' macro can be used in a macro command line for parameters which should not be formatted. Be careful to add ‘\&
' to the word ‘No
' if you really want that English word (and not the macro) as a parameter.
Usage: .No <argument> ...
.No test Ta with Ta tabs
The default width is 12n.
.Ns
' macro suppresses insertion of a space between the current position and its first parameter. For example, it is useful for old style argument lists where there is no space between the flag and argument:
Usage: ... <argument> Ns [<argument>] ...
.Ns <argument> ...
.Op Fl I Ns Ar directory
Note: The ‘.Ns
' macro always invokes the ‘.No
' macro after eliminating the space unless another macro name follows it. If used as a command (i.e., the second form above in the ‘Usage' line), ‘.Ns
' is identical to ‘.No
'.
.Sx
' macro designates a reference to a section header within the same document.
Usage: .Sx <section reference> ...
.Sx FILES
The default width is 16n.
Usage: .Sy <symbol> ...
.Sy Important Notice
The default width is 6n.
Usage: .Ms <math symbol> ...
.Ms sigma
The default width is 6n.
.Rs
.Re
.%A
.%B
.%C
.%D
.%I
.%J
.%N
.%O
.%P
.%Q
.%R
.%T
.%U
.%V
Macros beginning with ‘%
' are not callable but accept multiple arguments in the usual way. Only the ‘.Tn
' macro is handled properly as a parameter; other macros will cause strange output. ‘.%B
' and ‘.%T
' can be used outside of the ‘.Rs/.Re
' environment.
Example:
.Rs .%A "Matthew Bar" .%A "John Foo" .%T "Implementation Notes on foobar(1)" .%R "Technical Report ABC-DE-12-345" .%Q "Drofnats College, Nowhere" .%D "April 1991" .Re
produces
Usage: .Tn <symbol> ...
.Tn DEC
.Tn ASCII
The default width is 10n.
.Xo
and .Xc
macros allow one to extend an argument list on a macro boundary for the ‘.It
' macro (see below). Note that .Xo
and .Xc
are implemented similarly to all other macros opening and closing an enclosure (without inserting characters, of course). This means that the following is true for those macros also.
Here is an example of ‘.Xo
' using the space mode macro to turn spacing off:
.Sm off .It Xo Sy I Ar operation .No \en Ar count No \en .Xc .Sm on
produces
Another one:
.Sm off .It Cm S No / Ar old_pattern Xo .No / Ar new_pattern .No / Op Cm g .Xc .Sm on
produces
Another example of ‘.Xo
' and enclosure macros: Test the value of a variable.
.It Xo .Ic .ifndef .Oo \&! Oc Ns Ar variable Oo .Ar operator variable ... .Oc Xc
produces
.Sh
' section header macros are required in every man page. The remaining section headers are recommended at the discretion of the author writing the manual page. The ‘.Sh
' macro is parsed but not generally callable. It can be used as an argument in a call to ‘.Sh
' only; it then reactivates the default font for ‘.Sh
'.The default width is 8n.
.Sh NAME
.Sh NAME
' macro is mandatory. If not specified, headers, footers and page layout defaults will not be set and things will be rather unpleasant. The NAME section consists of at least three items. The first is the ‘.Nm
' name macro naming the subject of the man page. The second is the name description macro, ‘.Nd
', which separates the subject name from the third item, which is the description. The description should be the most terse and lucid possible, as the space available is small.
‘.Nd
' first prints ‘-
', then all its arguments.
.Sh LIBRARY
.Lb
' macro call; see Library Names..Sh SYNOPSIS
.Nm
', ‘.Cd
', or ‘.Fn
' (and possibly ‘.Fo
', ‘.Fc
', ‘.Fd
', and ‘.Ft
'). The function name macro ‘.Fn
' is required for manual page sections 2 and 3; the command and general name macro ‘.Nm
' is required for sections 1, 5, 6, 7, and 8. Section 4 manuals require a ‘.Nm
', ‘.Fd
' or a ‘.Cd
' configuration device usage macro. Several other macros may be necessary to produce the synopsis line as shown below:
The following macros were used:
.Nm cat
.Op Fl benstuv
.Op Fl
.Ar
.Sh DESCRIPTION
.Bl
' (begin list), ‘.It
' (list item) and ‘.El
' (end list) macros are used (see Lists and Columns below)..Sh IMPLEMENTATION NOTES
.Sh RETURN VALUES
.Rv
' macro may be used to generate text for use in the RETURN VALUES section for most section 2 and 3 library functions; see Return Values.
The following ‘.Sh
' section headers are part of the preferred manual page layout and must be used appropriately to maintain consistency. They are listed in the order in which they would be used.
.Sh ENVIRONMENT
.Sh FILES
.Pa
' macro in the FILES section..Sh EXAMPLES
.Sh DIAGNOSTICS
.Ex
' macro may be used to generate text for use in the DIAGNOSTICS section for most section 1, 6 and 8 commands; see Exit Status..Sh COMPATIBILITY
.Sh ERRORS
.Er
' macro is used to specify an error (errno)..Sh SEE ALSO
.Xr
' macro. Currently refer(1) style references are not accommodated.It is recommended that the cross references are sorted on the section number, then alphabetically (case-insensitive) on the names within a section, and placed in that order and comma separated. Example:
.Sh STANDARDS
.Sh HISTORY
.Sh AUTHORS
.An
' macro for names and the ‘.Aq
' macro for e-mail addresses within optional contact information. Explicitly indicate whether the person authored the initial manual page or the software or whatever the person is being credited for..Sh BUGS
User-specified ‘.Sh
' sections may be added; for example, this section was set with:
.Sh "PAGE STRUCTURE DOMAIN"
.Ss
' is parsed but not generally callable. It can be used as an argument in a call to ‘.Ss
' only; it then reactivates the default font for ‘.Ss
'.The default width is 8n.
.Pp
.Pp
' paragraph command may be used to specify a line space where necessary. The macro is not necessary after a ‘.Sh
' or ‘.Ss
' macro or before a ‘.Bl
' or ‘.Bd
' macro (which both assert a vertical distance unless the -compact flag is given).
The macro is neither callable nor parsed and takes no arguments; an alternative name is ‘.Lp
'.
.Bk
' (begin keep) and ‘.Ek
' (end keep). The only option that ‘.Bk
' accepts currently is -words (this is also the default if no option is given) which is useful for preventing line breaks in the middle of options. In the example for the make command line arguments (see What's in a Name), the keep prevented nroff from placing up the flag and the argument on separate lines.Both macros are neither callable nor parsed.
More work needs to be done with the keep macros; specifically, a -line option should be added.
.D1
-ldghfstru
The above was produced by: .D1 Fl ldghfstru
.
.Dl
.Dl
' example macro has been used throughout this file. It allows the indentation (display) of one line of text. Its default font is set to constant width (literal). ‘.Dl
' is parsed but not callable.
% ls -ldg /usr/local/bin
The above was produced by: .Dl % ls -ldg /usr/local/bin
.
.Bd
.Bd
' display must be ended with the ‘.Ed
' macro. It has the following syntax:
.Bd
{-literal | -filled | -unfilled | -ragged | -centered} [-offset <string>] [-file <file name>] [-compact]
.Bd
' and ‘.Ed
', using the selected display type. Any troff/-mdoc commands in the file will be processed.
.Bd
'..D1
' and ‘.Dl
' macros, so one is guaranteed the two types of displays will line up. The indentation value is normally set to 6n or about two thirds of an inch (six constant width characters).If <string> is a valid numeric expression instead (with a scale indicator other than ‘u'), use that value for indentation. The most useful scale indicators are ‘m' and ‘n', specifying the so-called Em and En square. This is approximately the width of the letters ‘m' and ‘n' respectively of the current font (for nroff output, both scale indicators give the same values). If <string> isn't a numeric expression, it is tested whether it is an -mdoc macro name, and the default offset value associated with this macro is used. Finally, if all tests fail, the width of <string> (typeset with a fixed-width font) is taken as the offset.
.Ed
.Bl
' begin-list macro. Items within the list are specified with the ‘.It
' item macro, and each list must end with the ‘.El
' macro. Lists may be nested within themselves and within displays. The use of columns inside of lists or lists inside of columns is unproven.In addition, several list attributes may be specified such as the width of a tag, the list offset, and compactness (blank lines between items allowed or disallowed). Most of this document has been formatted with a tag style list (-tag).
It has the following syntax forms:
.Bl
{-hang | -ohang | -tag | -diag | -inset} [-width <string>] [-offset <string>] [-compact].Bl
-column [-offset <string>] <string1> <string2> ....Bl
{-item | -enum [-nested] | -bullet | -hyphen | -dash} [-offset <string>] [-compact]And now a detailed description of the list types.
.Bl -bullet -offset indent -compact .It Bullet one goes here. .It Bullet two here. .El
Produces:
.Bl -dash -offset indent -compact .It Dash one goes here. .It Dash two here. .El
Produces:
.Bl -enum -offset indent -compact .It Item one goes here. .It And item two here. .El
The result:
If you want to nest enumerated lists, use the -nested flag (starting with the second-level list):
.Bl -enum -offset indent -compact .It Item one goes here .Bl -enum -nested -compact .It Item two goes here. .It And item three here. .El .It And item four here. .El
Result:
.Bl -item -offset indent .It Item one goes here. Item one goes here. Item one goes here. .It Item two here. Item two here. Item two here. .El
Produces:
The raw text:
.Bl -tag -width "PPID" -compact -offset indent .It SL sleep time of the process (seconds blocked) .It PAGEIN number of disk .Tn I/O Ns 's resulting from references by the process to pages not loaded in core. .It UID numerical user-id of process owner .It PPID numerical id of parent of process priority (non-positive when in non-interruptible wait) .El
Example:
.Bl -diag .It You can't use Sy here. The message says all. .El
produces
And the unformatted text which created it:
.Bl -hang -offset indent .It Em Hanged labels appear similar to tagged lists when the label is smaller than the label width. .It Em Longer hanged list labels blend into the paragraph unlike tagged paragraph labels. .El
The raw text:
.Bl -ohang -offset indent .It Sy SL sleep time of the process (seconds blocked) .It Sy PAGEIN number of disk .Tn I/O Ns 's resulting from references by the process to pages not loaded in core. .It Sy UID numerical user-id of process owner .It Sy PPID numerical id of parent of process priority (non-positive when in non-interruptible wait) .El
Here is the source text which produced the above example:
.Bl -inset -offset indent .It Em Tag The tagged list (also called a tagged paragraph) is the most common type of list used in the Berkeley manuals. .It Em Diag Diag lists create section four diagnostic lists and are similar to inset lists except callable macros are ignored. .It Em Hang Hanged labels are a matter of taste. .It Em Ohang Overhanging labels are nice when space is constrained. .It Em Inset Inset labels are useful for controlling blocks of paragraphs and are valuable for converting .Nm -mdoc manuals to other formats. .El
.
' (dot) immediately followed by a valid -mdoc macro name, interpret <stringN> and use the width of the result. Otherwise, the width of <stringN> (typeset with a fixed-width font) is taken as the Nth column width.
Each ‘.It
' argument is parsed to make a row, each column within the row is a separate argument separated by a tab or the ‘.Ta
' macro.
The table:
String | Nroff | Troff |
<= |
<= | ≤ |
>= |
>= | ≥ |
was produced by:
.Bl -column -offset indent ".Sy String" ".Sy Nroff" ".Sy Troff" .It Sy String Ta Sy Nroff Ta Sy Troff .It Li <= Ta <= Ta \*(<= .It Li >= Ta >= Ta \*(>= .El
Other keywords:
.
' (dot) immediately followed by a valid -mdoc macro name, interpret <string> and use the width of the result. Almost all lists in this document use this option.Example:
.Bl -tag -width ".Fl test Ao Ar string Ac" .It Fl test Ao Ar string Ac This is a longer sentence to show how the .Fl width flag works in combination with a tag list. .El
gives:
(Note that the current state of -mdoc is saved before <string> is interpreted; afterwards, all variables are restored again. However, boxes (used for enclosures) can't be saved in GNU troff(1); as a consequence, arguments must always be balanced to avoid nasty errors. For example, do not write ‘.Ao Ar string
' but ‘.Ao Ar string Xc
' instead if you really need only an opening angle bracket.)
Otherwise, if <string> is a valid numeric expression (with a scale indicator other than ‘u'), use that value for indentation. The most useful scale indicators are ‘m' and ‘n', specifying the so-called Em and En square. This is approximately the width of the letters ‘m' and ‘n' respectively of the current font (for nroff output, both scale indicators give the same values). If <string> isn't a numeric expression, it is tested whether it is an -mdoc macro name, and the default width value associated with this macro is used. Finally, if all tests fail, the width of <string> (typeset with a fixed-width font) is taken as the width.
If a width is not specified for the tag list type, every time ‘.It
' is invoked, an attempt is made to determine an appropriate width. If the first argument to ‘.It
' is a callable macro, the default width for that macro will be used; otherwise, the default width of ‘.No
' is used.
.Dl
' or ‘.Bd
') is used. If <string> is a valid numeric expression instead (with a scale indicator other than ‘u'), use that value for indentation. The most useful scale indicators are ‘m' and ‘n', specifying the so-called Em and En square. This is approximately the width of the letters ‘m' and ‘n' respectively of the current font (for nroff output, both scale indicators give the same values). If <string> isn't a numeric expression, it is tested whether it is an -mdoc macro name, and the default offset value associated with this macro is used. Finally, if all tests fail, the width of <string> (typeset with a fixed-width font) is taken as the offset..Me
' and ‘.Ot
'. They are documented here for completeness - if you know how to use them properly please send a mail to bug-groff@gnu.org (including an example)..Bt
It is neither callable nor parsed and takes no arguments.
.Fr
Usage: .Fr <function return value> ...
Don't use this macro. It allows a break right before the return value (usually a single digit) which is bad typographical behaviour. Use ‘\~
' to tie the return value to the previous word.
.Hf
File:
' followed by the file name, then the contents of <file>.
Usage: .Hf <file>
It is neither callable nor parsed.
.Lk
Usage: .Lk <href> [anchor-text]
.Me
Its default width is 6n.
.Mt
Usage: .Mt <email_address>
.Ot
.Sm
Usage: .Sm [on | off] ...
If space mode is off, no spaces between macro arguments are inserted. If called without a parameter (or if the next parameter is neither ‘on
' nor ‘off
', ‘.Sm
' toggles space mode.
.Ud
It is neither callable nor parsed and takes no arguments.
String | Nroff | Troff | Meaning |
<= |
<= | ≤ | less equal |
>= |
>= | ≥ | greater equal |
Rq |
'' | ” | right double quote |
Lq |
`` | “ | left double quote |
ua |
^ | ↑ | upwards arrow |
aa |
́ | ́ | acute accent |
ga |
̀ | ̀ | grave accent |
q |
" | " | straight double quote |
Pi |
pi | pi | greek pi |
Ne |
!= | ≠ | not equal |
Le |
<= | ≤ | less equal |
Ge |
>= | ≥ | greater equal |
Lt |
< | < | less than |
Gt |
> | > | greater than |
Pm |
+- | ± | plus minus |
If |
infinity | infinity | infinity |
Am |
& | & | ampersand |
Na |
NaN | NaN | not a number |
Ba |
| | | | vertical bar |
The names of the columns Nroff and Troff are a bit misleading; Nroff shows the ASCII representation, while Troff gives the best glyph form available. For example, a Unicode enabled TTY-device will have proper glyph representations for all strings, whereas the enhancement for a Latin1 TTY-device is only the plus-minus sign.
String names which consist of two characters can be written as ‘\*(xx
'; string names which consist of one character can be written as ‘\*x
'. A generic syntax for a string name of any length is ‘\*[xxx]
' (this is a GNU troff(1) extension).
.Db
' available in previous versions of -mdoc has been removed since GNU troff(1) provides better facilities to check parameters; additionally, many error and warning messages have been added to this macro package, making it both more robust and verbose.
The only remaining debugging macro is ‘.Rd
' which yields a register dump of all global registers and strings. A normal user will never need it.
cR
' to zero while calling groff(1), resulting in multiple pages instead of a single, very long page:
groff -Tlatin1 -rcR=0 -mdoc foo.man > foo.txt
For double-sided printing, set register ‘D
' to 1:
groff -Tps -rD1 -mdoc foo.man > foo.ps
To change the document font size to 11pt or 12pt, set register ‘S
' accordingly:
groff -Tdvi -rS11 -mdoc foo.man > foo.dvi
Register ‘S
' is ignored for TTY devices.
The line and title length can be changed by setting the registers ‘LL
' and ‘LT
', respectively:
groff -Tutf8 -rLL=100n -rLT=100n -mdoc foo.man | less
If not set, both registers default to 78n for TTY devices and 6.5i otherwise.
‘.Nm
' font should be changed in NAME section.
‘.Fn
' needs to have a check to prevent splitting up if the line length is too short. Occasionally it separates the last parenthesis, and sometimes looks ridiculous if a line is in fill mode.
The list and display macros do not do any keeps and certainly should be able to.
November 17, 2009 | NetBSD 6.1 |