RADIO(4) | Kernel Interfaces Manual | RADIO(4) |
#include <sys/types.h>
#include <sys/ioctl.h>
#include <sys/radioio.h>
For radio tuner controlling there is a single device file available: /dev/radio.
The following ioctl(2) commands are supported:
struct radio_info { int mute; int volume; int stereo; int rfreq; /* reference frequency */ int lock; /* locking field strength */ uint32_t freq; /* in kHz */ uint32_t caps; /* card capabilities */ #define RADIO_CAPS_DETECT_STEREO (1<<0) #define RADIO_CAPS_DETECT_SIGNAL (1<<1) #define RADIO_CAPS_SET_MONO (1<<2) #define RADIO_CAPS_HW_SEARCH (1<<3) #define RADIO_CAPS_HW_AFC (1<<4) #define RADIO_CAPS_REFERENCE_FREQ (1<<5) #define RADIO_CAPS_LOCK_SENSITIVITY (1<<6) #define RADIO_CARD_TYPE (0xFF<<16) uint32_t info; #define RADIO_INFO_STEREO (1<<0) #define RADIO_INFO_SIGNAL (1<<1) };
The mute field is a boolean.
The volume field holds the card volume information and can be at most 255.
The stereo field is a boolean.
The rfreq holds information about the card reference frequency (not all cards support this feature).
The lock field holds information about the card locking field strength during an automatic search for cards that support this feature.
The freq field is the frequency in kHz the card is tuned to.
The caps field is read-only and describes the card capabilities. The capabilities can have following values:
The info field is read-only and describes the current state of the card - tuned/not tuned, stereo signal/mono signal.
October 20, 2001 | NetBSD 6.1 |