PATHBUF(9) | Kernel Developer's Manual | PATHBUF(9) |
struct pathbuf *
pathbuf_create(const char *path);
struct pathbuf *
pathbuf_assimilate(char *pnbuf);
int
pathbuf_copyin(const char *userpath, struct pathbuf **ret);
void
pathbuf_destroy(struct pathbuf *path);
The pathbuf_create() function allocates and initializes a new pathbuf containing a copy of the path string path, which should be a kernel pointer. The return value should be checked for being NULL in case the system is out of memory. Passing a path name larger than PATH_MAX will cause an assertion failure.
The pathbuf_copyin() function allocates and initializes a new pathbuf containing a path string copied from user space with copyinstr(9). It returns an error code.
The pathbuf_assimilate() function creates a pathbuf using the string buffer provided as pnbuf. This buffer must be of size PATH_MAX and must have been allocated with PNBUF_GET(). The buffer is “taken over” by the returned pathbuf and will be released when the pathbuf is destroyed. Note: to avoid confusion and pointer bugs, pathbuf_assimilate() should only be used where absolutely necessary; e.g. the NFS server code uses it to generate pathbufs from strings fetched from mbufs.
The pathbuf_destroy() function deallocates a pathbuf. Caution: because calling namei(9) loads pointers to memory belonging to the pathbuf into the nameidata structure, a pathbuf should only be destroyed by the namei() caller once all manipulations of the nameidata are complete.
Also note that calling namei() destroys the contents of the pathbuf. Do not reuse a pathbuf for a second call to namei().
November 30, 2010 | NetBSD 6.1 |