MICROTIME(9) | Kernel Developer's Manual | MICROTIME(9) |
void
bintime(struct bintime *bt);
void
getbintime(struct bintime *bt);
void
microtime(struct timeval *tv);
void
getmicrotime(struct timeval *tv);
void
nanotime(struct timespec *ts);
void
getnanotime(struct timespec *tsp);
The bintime(), microtime(), and nanotime() functions always query the timecounter to return the current time as precisely as possible. Whereas getbintime(), getmicrotime(), and getnanotime() functions are abstractions which return a less precise, but faster to obtain, time.
The intent of the getbintime(), getmicrotime(), and getnanotime() functions is to enforce the user's preference for timer accuracy versus execution time. They should be used where a precision of 1/HZ (e.g., 10 msec on a 100HZ machine, see hz(9)) is acceptable or where performance is priority.
The system realtime clock is guaranteed to be monotonically increasing at all times. As such, all calls to these functions are guaranteed to return a system time greater than or equal to the system time returned in any previous calls. Comparable functions exist to retrieve the time elapsed since boot; see microuptime(9).
The implementation of the time counter sources used by the timecounter(9) is machine dependent, hence its location in the source code tree varies from architecture to architecture.
June 8, 2010 | NetBSD 6.1 |