SHMIF(4) Kernel Interfaces Manual SHMIF(4)

NAME

shmifrump shared memory network interface

SYNOPSIS

#include <rump/rump.h>

int
rump_pub_shmif_create(const char *path, int *ifnum);

DESCRIPTION

The shmif interface uses a memory mapped regular file as a virtual Ethernet bus. All interfaces connected to the same bus see each others' traffic.

Using a memory mapped regular file as a bus has two implications:

  1. The bus identifier is not in flat global namespace.
  2. Configuring and using the interface is possible without superuser privileges on the host (normal host file access permissions for the bus hold).

It is not possible to directly access the host networking facilities from a rump virtual kernel using purely shmif. However, traffic can be routed to another rump kernel instance which provides both shmif and virt(4) networking.

An shmif interface can be created in two ways:

Destroying an shmif interface is possible only via ifconfig(8) destroy.

SEE ALSO

rump(3), virt(4), ifconfig(8)
November 17, 2010 NetBSD 6.1