FSS(4) | Kernel Interfaces Manual | FSS(4) |
The (third) argument to ioctl(2) should be a pointer to the type indicated.
struct fss_set { char *fss_mount; char *fss_bstore; blksize_t fss_csize; int fss_flags; };
The struct element fss_mount is the mount point of the file system. The struct element fss_bstore is either a regular file or a raw disk device where data overwritten on the file system will be saved. The struct element fss_csize is the preferred size of this data. The struct element fss_flags is the initial set of flags.
struct fss_get { char fsg_mount[MNAMELEN]; struct timeval fsg_time; blksize_t fsg_csize; blkcnt_t fsg_mount_size; blkcnt_t fsg_bs_size; };The struct element fsg_mount is the mount point of the file system. The struct element fsg_time is the time this snapshot was taken. The struct element fsg_csize is the current size of data clusters. The struct element fsg_mount_size is the number of clusters of the file system. The struct element fsg_bs_size is the number of clusters written to the backing store.
February 24, 2011 | NetBSD 6.1 |