AHSC(4) Kernel Interfaces Manual (Amiga) AHSC(4)

NAME

ahscA3000 low level SCSI interface

SYNOPSIS

ahsc0 at mainbus0

DESCRIPTION

The Amiga architecture uses a common machine independent scsi sub-system provided in the kernel source. The machine independent drivers that use this code access the hardware through a common interface. (see scsibus(4)) This common interface interacts with a machine dependent interface, such as ahsc, which then handles the hardware specific issues.

The ahsc interface handles things such as DMA and interrupts as well as actually sending commands, negotiating synchronous or asynchronous transfers and handling disconnect/reconnect of SCSI targets. The hardware that ahsc uses is based on the WD33c93 SCSI chip.

DIAGNOSTICS

sbicwait TIMEO @%d with asr=x%x csr=x%x
The 33c93 code (sbic) has been waiting too long for a SCSI chip operation to complete. %d is the line in the source file amiga/dev/sbic.c at which the SCSI chip timed-out. Asr and csr are status registers within the SCSI chip.
ahsc%d: abort %s: csr = 0x%02x, asr = 0x%02x
A SCSI operation %s was aborted due to an error.
ahsc%d: csr == 0x%02i
A error has occurred within the SCSI chip code.
ahsc%d: unexpected phase %d in icmd from %d
The target described by ‘from %d' has taken the SCSI bus into a phase which is not expected during polled IO.
ahsc%d: unexpected phase %d in icmd from %d
The target described by ‘from %d' has taken the SCSI bus into a phase which is not expected during DMA IO setup.

SEE ALSO

scsibus(4)

HISTORY

The ahsc interface first appeared in NetBSD 1.0
August 31, 1994 NetBSD 6.1