Creates, updates, and manages multiple versions of the Base Operating System (BOS) on a rootvg.
multibos -s [-l device {-a | -f file | -b file | -x file}] [-e file] [-i file] [-L file] [-pntNX]
multibos -c -l device {-a | -f file | -b file | -x file} [-pnNX]
The multibos command allows the root level administrator to create multiple instances of AIX® on the same rootvg. The multibos setup operation creates a standby Base Operating System (BOS) that boots from a distinct boot logical volume (BLV). This creates two bootable sets of BOS on a given rootvg. The administrator can boot from either instance of BOS by specifying the respective BLV as an argument to the bootlist command or using system firmware boot operations. Two bootable instances of BOS can be simultaneously maintained. The instance of BOS associated with the booted BLV is referred to as the active BOS. The instance of BOS associated with the BLV that has not been booted is referred to as the standby BOS. Currently, only two instances of BOS are supported per rootvg.
The multibos command allows the administrator to access, install maintenance and technology levels for, update, and customize the standby BOS either during setup or in subsequent customization operations. Installing maintenance and technology updates to the standby BOS does not change system files on the active BOS. This allows for concurrent update of the standby BOS, while the active BOS remains in production.
In addition, the multibos command copies or shares logical volumes and file systems. By default, the BOS file systems (currently /, /usr, /var, and /opt,) and the boot logical volume are copied. The administrator can make copies of additional BOS objects (using the -L flag).
All other file systems and logical volumes are shared between instances of BOS. Separate log device logical volumes (for example, those that are not contained within the file system) are not supported for copy and are shared.
Item | Description |
---|---|
-a | Specifies the update_all install option. Valid with setup and customization operation. |
-B | Build boot image operation. The standby boot image is created and written to the standby BLV using the AIX bosboot command. |
-b file | Specifies the install bundle to be installed during the setup or customization operation. The install bundle syntax should follow geninstall conventions. |
-c | Performs a customized update of the software in standby BOS. |
-e file | Lists active BOS files to be excluded during the setup operation in regular expression syntax. |
-f file | Lists fixes (such as APARs) that are to be installed during the setup or customization operation. The syntax of the list follows instfix conventions. |
-i file | Specifies optional image.data file to use instead of the default image.data file created from the current rootvg. |
-L file | Specifies a file that contains a list of additional logical volumes to include in standby BOS. |
-l device | Installs device or directory for software update during the setup or customization operation. |
-m | Mounts standby BOS. |
-M file | Specifies a file that contains a mksysb image. The mksysb image must have been created using the mksysb -M command beginning with AIX 6.1 with 6100-02. |
-N | Skips boot image processing. This flag should only be used by experienced administrators that have a good understanding of the AIX boot process. |
-n | Does not perform cleanup upon failure. This option is useful to retain multibos data after a failed operation. |
-p | Performs a preview of the given operation. Valid with setup, remove, mount, unmount, and customization operations. |
-R | Removes all standby BOS objects. |
-S | Initiates an interactive shell with chroot access to the standby BOS file systems. |
-s | Creates an instance of standby BOS. |
-t | Prevents multibos from changing the bootlist. |
-u | Unmounts standby BOS. |
-x file | Runs the optional customization script before any other customized parameters, such as, update_all (-a), install bundle file (-b), and fix list file (-f). You must use a full pathname for the script. |
-X | Allows for automatic file system expansion if space is needed to perform tasks related to multibos. It is recommended that all multibos operations are executed with this flag. |
Item | Description |
---|---|
0 | All the multibos command operations completed successfully. |
>0 | An error occurred. |
Only the root user can run the multibos command.
multibos -Xsp
multibos -Xs
multibos -Xs -i /tmp/image.data -e /tmp/exclude.list
multibos -Xs -b /tmp/bundle -l /images
multibos -Xac -l /images
multibos -Xm
multibos -RXp
multibos -RX
multibos -M /backups/mksysb1 -sX
Item | Description |
---|---|
/usr/sbin/multibos | Contains the multibos command. |
/etc/multibos | Contains multibos data and logs. |