Installs available software products in a compatible installation package.
To Install with Apply Only or with Apply and Commit
installp [ -R path ] [ -a | -a -c [ -N ] ] [ -eLogFile ] [ -V Number ] [ -dDevice ] [ -E ] [ -Y ] [ -b ] [ -S ] [ -B ] [ -D ] [ -I ] [ -p ] [ -Q ] [ -q ] [ -v ] [ -X ] [ -F | -g ] [ -O { [ r ] [ s ] [ u ] } ] [ -t SaveDirectory ] [ -w ] [ -zBlockSize ] { FilesetName [ Level ]... | -f ListFile | all }
To Commit Applied Updates
installp [ -R path ] -c [ -eLogFile ] [ -VNumber ] [ -b ] [ -g ] [ -p ] [ -v ] [ -X ] [ -O { [ r ] [ s ] [ u ] } ] [ -w ] { FilesetName [ Level ]... | -f ListFile | all }
To Reject Applied Updates
installp [ -R path ] -r [ -eLogFile ] [ -VNumber ] [ -b ] [ -g ] [ -p ] [ -v ] [ -X ] [ -O { [ r ] [ s ] [ u ] } ] [ -w ] { FilesetName [ Level ]... | -f ListFile }
To Deinstall (Remove) Installed Software
installp [ -R path ] -u [ -eLogFile ] [ -VNumber ] [ -b ] [ -g ] [ -p ] [ -v ] [ -X ] [ -O { [ r ] [ s ] [ u ] } ] [ -w ] { FilesetName [ Level ]... | -f ListFile }
To Clean Up a Failed Installation:
installp [ -R path ] -C [ -b ] [ -eLogFile ]
To List All Installable Software on Media
installp { -l | -L } [ -eLogFile ] [ -d Device ] [ -B ] [ -I ] [ -q ] [-E ] [ -zBlockSize ] [ -O { [ s ] [ u ] } ]
To List All Customer-Reported Problems Fixed with Software or Display All Supplemental Information
installp { -A| -i } [ -eLogFile ] [ -dDevice ] [ -B ] [ -I ] [ -q ] [ -z BlockSize ] [ -O { [ s ] [ u ] } ] { FilesetName [ Level ]... | -f ListFile | all }
To List Installed Updates That Are Applied But Not Committed
installp -s [ -eLogFile ] [ -O { [ r ] [ s ] [ u ] } ] [ -w ] { FilesetName [ Level ]... | -fListFile | all }
To List Platform Specific Installable Software on Media
installp { -l | -L } { -MPlatform } [ -eLogFile ] [ -d Device ] [ -B ] [ -I ] [ -q ] [ -z BlockSize ] [ -O { [ s ] [ u ] } ]
The installp command installs and updates software.
A fileset is the lowest installable base unit. For example, bos.net.tcp.client 4.1.0.0 is a fileset. A fileset update is an image with a different modification level or a different fix level. For example, bos.net.tcp.client 4.1.0.2 and bos.net.tcp.client 4.1.1.0 are both fileset updates for bos.net.tcp.client 4.1.0.0.
When a base level (fileset) is installed on the system, it is automatically committed. You can remove a fileset regardless of the state (such as committed, broken, committed with applied updates, and committed with committed updates).
When a fileset update is applied to the system, the update is installed. The current version of that software, during installation, is saved in a special save directory on the disk so that later you can return to that version if desired. After a new version of a software product has been applied to the system, that version becomes the currently active version of the software.
Updates that have been applied to the system can be either committed or rejected at a later time. The installp -s command can be used to get a list of applied updates that can be committed or rejected.
When a base level is removed with the -u flag, the files that are part of the software product and all its updates are removed from the system. Most cleanup of system configuration information pertaining to the product is also done, but this is dependent on the product and may not always be complete.
When a software product update is rejected with the -r flag, the current version of the software product is changed to the immediate previous version of the update. Files saved for the rejected update and any updates that were applied after it are removed from the system.
A software product that is to be removed from the system can be in any state. Product updates can be in either the applied or committed state, and they will also be removed.
If a previously interrupted installation leaves any software in a state of either applying or committing, it is necessary to perform cleanup with the -C flag before any further installations are allowed. Although the installp -C command accepts software product names on the command line without returning an error, an attempt is always made to clean up all products when the -C flag is used. An attempt is made to clean up any incomplete installations by removing those parts that were previously completed. An attempt is also made to return to the previous version of the software product, if one exists, as the currently active version. If this cannot be done, the software product is marked as broken, and unpredictable results can occur if the user attempts to use it. Therefore, it is advisable for the user to reinstall any broken software products or updates.
The -t flag specifies an alternate location for a save directory that holds files being replaced by an update. This option is primarily useful in the following two circumstances.
In this case, you can choose to create a separate file system for the alternate save directory. When you are satisfied with the updated system and have committed all applied updates, disk space can be retrieved by deleting the save file system.
If a remote file system is used, commit the updates as soon as possible. You may want to initiate the installation action as an apply and commit operation with the -ac flags. If you want to apply only to be able to reject unwanted updates, then test the newly installed updates as soon as possible and then commit or reject them.
Take into account the following considerations when using an alternate save directory:
The installp -A command can be used to obtain a list of the Authorized Program Analysis Report (APAR) numbers and summaries for all customer-reported problems that are fixed in the specified software package. The installp -i command can be used to display supplemental information contained in files that can be a part of the specified software package.
To list all the software products and updates on the specified installation media, use the installp -l command. The output of the installp command with the -l flag resembles the following:
# Fileset Name Level I/U Q Content
#================================================================
X11.adt.include 4.1.0.0 I N usr
# AIX windows Application Development Toolkit Include F
X11.adt.lib 4.1.0.0 I N usr
# AIX windows Application Development Toolkit Libraries
#
X11.adt.motif 4.1.0.0 I N usr
# AIX windows Application Development Toolkit Motif
#
X11.adt.bitmaps 4.1.0.0 I N usr
# AIX windows Application Development Toolkit Bitmap Fi
#
X11.adt.ext 4.1.0.0 I N usr
# AIX windows Application Development Toolkit for X Ext
#
X11.adt.imake 4.1.0.0 I N usr
# AIX windows Application Development Toolkit imake
#
X11.apps.rte 4.1.0.0 I N usr
# AIX windows Runtime Configuration Applications
#
X11.apps.msmit 4.1.0.0 I N usr
# AIX windows msmit Application
The field descriptions are as follows:
Item | Description |
---|---|
Fileset Name | Name of the fileset to be installed. |
Level | Level of the fileset to be installed. |
I/U | The type of package to which the fileset belongs. The fileset
can belong to an installation package or to one of several types of
update packages. The package types are as follows:
|
Q | Quiescent (quiet) column. A Y indicates that running processes can be affected by the installation of this fileset. Refer to the documentation supplied with the software product. An N indicates that running processes are not affected by the installation of this fileset. A B indicates bosboot and quiescent. A b indicates bosboot and not quiescent. |
Content | Content column:
|
Output from the installp -s command, which is used to get a list of applied software fileset updates and updates that are available to be either committed or rejected, resembles the following:
Installp Status
---------------
Name Part Level State
--------------------------------------------------------------------
bos.net.tcp.client USR 4.1.0.2 APPLIED
bos.net.tcp.client ROOT 4.1.0.2 APPLIED
bos.rte.commands USR 4.1.0.1 APPLIED
bos.rte.misc_cmds USR 4.1.0.1 APPLIED
bos.rte.tty USR 4.1.0.1 APPLIED
The field descriptions are as follows:
Item | Description |
---|---|
Name | Name of the installed software product fileset. |
Part | The part of the fileset where: |
ROOT | root file system |
SHARE | /usr/share file system |
USR | /usr file system. |
Level | The level of the installed software product option. |
State | The state of the installed software product option. |
The software products and updates to be installed can be identified in one of following ways:
The FilesetName parameter can be used to specify an entire software product or any separately installable filesets within the software package. For example, bos.net is the name of a software package, and the separately installable filesets within that software package are bos.net.ncs.client, bos.net.nfs.client, and bos.net.tcp.client. If the user specifies bos.net for the FilesetName parameter, then all of the separately installable filesets listed are installed. If the user specifies bos.net.tcp.client for the FilesetName parameter, then only that fileset is installed.
The Level parameter indicates the level of the software product or update that is to be installed. The Level parameter is of the form vv.rr.mmmm.ffff where:
Item | Description |
---|---|
vv | is a numeric field of 1 to 2 digits that represents the version number. |
rr | is a numeric field of 1 to 2 digits that represents the release number. |
mmmm | is a numeric field of 1 to 4 digits that represents the modification level. Modification level is also called maintenance level or technology level. |
ffff | is a numeric field of 1 to 4 digits that represents the fix level. |
If a user is installing an installation package from installation media that contains only installation packages it is not necessary to specify the level. More than one software product installation package with different levels does not often exist on the same installation medium. However, when this does occur installp installs the specified software product at the latest software product level when Level is not specified with FilesetName. For installation media that contain either update packages only or contain both installation and update packages, all applicable update packages that are present on the installation media for the specified FilesetName are also installed when Level is not specified. For installation media that contain both installation and update packages the user can request the installation of only installation packages or only update packages by specifying the -I or -B flags, respectively. If the user wants to install only some of the updates on the installation medium for a specific software product both FilesetName and Level for each of the updates to be installed for that software product must be specified.
You can use the following example to install TCP/IP and one of its updates that are both contained in the /usr/sys/inst.images directory.
installp -a -d/usr/sys/inst.images bos.net.tcp.client 4.1.0.0
bos.net.tcp.client 4.1.0.2
A summary report is given at the end of the installp output that lists the status of each of the software products that were to be installed. An example summary report for the previous installp command is as follows:
Installp Summary
----------------
Name Level Part Event Result
--------------------------------------------------------------------
bos.net.tcp.client 4.1.0.0 USR APPLY SUCCESS
bos.net.tcp.client 4.1.0.0 ROOT APPLY SUCCESS
bos.net.tcp.client 4.1.0.2 USR APPLY SUCCESS
The summary report identifies the name of the product option and the part of the product. Other information given includes the requested action (event) and the result of that action.
Event Values
The Event column of the summary report identifies the action that has been requested of the installp command. The following values are displayed in this column:
Event | Definition |
---|---|
APPLY | An attempt was made to apply the specified fileset. |
COMMIT | An attempt was made to commit the specified fileset update. |
REJECT | An attempt was made to reject the specified fileset update. |
CLEANUP | An attempt was made to perform cleanup for the specified fileset. |
DEINSTALL | An attempt was made to remove the specified fileset. |
Result Values
The Result column of the summary report gives the result of installp performing the requested action. It can have the following values:
Result | Definition |
---|---|
SUCCESS | The specified action succeeded. |
FAILED | The specified action failed. |
CANCELLED | Although preinstallation checking passed for the specified option, it was necessary to cancel the specified action before it was begun. Interrupting the installation process with Ctrl+c can sometimes cause a canceled action, although, in general, a Ctrl+c interrupt causes unpredictable results. |
Item | Description |
---|---|
-A | Displays the APAR number and summary of all customer-reported problems that are fixed in the specified software package. No installation is attempted. |
-a | Applies one or more software products or updates. This is the default action. This flag can be used with the -c flag to apply and commit a software product update when installed. |
-b | Prevents the system from performing a bosboot in the event that one is needed. |
-B | Indicates that the requested action should be limited to software updates. |
-C | Cleans up after an interrupted installation and attempts to remove all incomplete pieces of the previous installation. Cleanup must be performed whenever any software product or update is in a state of either applying or committing and can be run manually as needed. For backward compatibility, other flags and parameters can be accepted with installp -C, but are ignored because all necessary cleanup is attempted. |
-c | Commits all specified updates that are currently applied but not committed. When an update is committed all other software products it is dependent on must also be committed (unless they are already in the committed state). The specified software product is dependent on any software product that is a prerequisite or corequisite of the specified product. If the requisite software products are not in the committed state, the commit fails and error messages are displayed. The -g flag can be used to automatically commit requisite software product updates. |
-D | Deletes the installation image file after the software product or update has been successfully installed. When the -g flag is specified, the installation image files for any products that are automatically included are also deleted. This flag is valid only with the -a or -ac flags and is not valid with the -Or flag. This flag is also only valid when the device is a directory and an installation image file on the system where the installation is taking place. |
-d Device | Specifies where the installation media can be found. This can be a hardware device such as tape or diskette, it can be a directory that contains installation images, or it can be the installation image file itself. When the installation media is a product tape or Corrective Service tape, specified the tape device as no-rewind-on-close and no-retension-on-open. Examples of this would be /dev/rmt0.1 for a high density tape, or /dev/rmt0.5 for a low density tape. Use the options specified by the tape supplier. The default device is /dev/rfd0. |
-e LogFile | Enables event logging. The -e flag enables the user
to append certain parts of the installp command output to the
file specified by the LogFile variable. By default the output
of the installp command goes to stdout and stderr,
unless SMIT or VSM is used, in which case the output goes to the smit.log.
The LogFile variable must specify an existing, writable file,
and the file system in which the file resides must have enough space
to store the log. The log file does not wrap. Not all output is appended. Copyright information is still displayed to the user. Error messages are displayed on the screen and are sent to the file specified by the LogFile variable. A results summary of the installp command invocation is also displayed on the screen and sent to the LogFile. This flag is primarily used by NIM and BOS install to limit the output shown to the user, but keep useful information for later retrieval. |
-E | Displays software license agreements. This flag is only valid with the -a or -l flags. If the -E flag is specified with the -a flag, a new section is displayed showing the pending license agreements associated with the selected filesets. If the -E flag is specified with the -l flag, output is displayed showing the license agreements associated with all filesets on the media. |
-F | This option can be used to force the installation of a software product even if there exists a previously installed version of the software product that is the same as or newer than the version currently being installed. The -F flag is not valid with update packages or the -g flag. When you use the -F flag, the -I flag is implicit. |
-f ListFile | Reads the names of the software products from ListFile. If ListFile is a - (dash), it reads the list of names from the standard input. Software fileset names, optionally followed by a level, should be one per line of text, and any text following the second set of white spaces or tabs on a line is ignored. Output from the installp -l command is suitable for input to this flag. |
-g | When used to install or commit, this flag automatically installs
or commits, respectively, any software products or updates that are
requisites of the specified software product. When used to remove
or reject software, this flag automatically removes or rejects dependents
of the specified software. The -g flag is not valid when used
with the -F flag. Note: This flag also automatically pulls
in a superseding update present on the media if the specified update
is not present. This flag causes the newest update to be installed
for a given fileset, when there are multiple superseding updates for
the same fileset on the installation media.
|
-I | (uppercase i) Indicates that the requested action must be limited to base level filesets. |
-i | Displays on standard output the lpp.instr, lpp.doc, lpp.README, and README files on the installation media for the software product, if they exist. This flag can take a significant amount of time for a large number of filesets. |
-J | This flag is used when the installp command is executed from the System Management Interface Tool (SMIT) menus. |
-l | (lowercase L) Lists all the software products and their separately installable options contained on the installation media to standard output. No installation occurs. The -l flag is not valid with the -Or flag. |
-L | Displays the contents of the media by looking at the table
of contents (TOC) and displaying the information in colon-separated
output. This flag is used by smit and vsm to list content of the media.
The format provided:
|
-MPlatform | Specifies the Platform value. Any of the following values
can be used to list the installable software packages:
|
-N | Overrides saving of existing files that are replaced when installing or updating. This flag is valid only with the -ac flags. If there is a failure in the system during the installation, there is no recovery of replaced files when this flag is used. |
-O{[r][s][u]} | Installs the specified part of the software product. The r indicates the / (root) part is to be installed, the s indicates the /usr/share part is to be installed, and the u indicates the /usr part is to be installed. The -O flag is not needed with standard systems because without this flag all parts are installed by default. This flag is needed for use with the installation of diskless or dataless workstations and is designed for use by the nim command. The -Or option is not valid with the -d or -l flags. |
-p | Performs a preview of an action by running all preinstallation checks for the specified action. This flag is only valid with apply, commit, reject, and remove (-a, -c, -r, and -u) flags. |
-Q | Suppresses errors and warnings concerning products failing to install due to instrequisites. This flag applies only to AIX 4.2 or later. |
-q | Specifies quiet mode, which suppresses the prompt for the device, except for media volume change. |
-r | Rejects all specified software updates that are currently applied but not committed. When a software update is rejected any other software product that is dependent on it (that is, those software products that have the specified software product as a requisite) must also be rejected. The -g flag can be used to reject automatically dependent software updates. The keyword all is not valid with the reject flag (-r). |
-R path | Indicates a user-specified installation location. |
-s | Lists information about all software products and updates that have been applied but not committed. This list comprises the software that is available to be either committed or rejected. |
-S | Suppresses multiple volume processing when the installation device is a CD-ROM. Installation from a CD_ROM is always treated as a single volume, even if the CD-ROM contains information for a multiple volume CD set. This same suppression of multiple volume processing is performed if the INU_SINGLE_CD environment is set. |
-t SaveDirectory | Specifies an alternate save directory location for files
being replaced by an update. The -t flag is only valid with an apply or an apply/commit operation for updates. This flag is not valid with the -N flag. The -t flag is useful when there is insufficient space in the default file systems (/ and /usr) or when it is undesirable to permanently expand these file systems. It may be desirable for the specified directory to be a remote file system. A remote file system must have ample space, because the installp command cannot expand remote file systems. |
-u | Removes the specified software product and any of its installed updates from the system. The product can be in either the committed or broken state. Any software products that are dependent on the specified product must also be explicitly included in the input list unless the -g flag is also specified. Removal of any bos.rte fileset is never permitted. |
-v | Verifies that all installed files in the fileset have the correct checksum value after the installation. Installed files are always verified for correct file size after installation. Use this flag after network or remote device installations. If any errors are reported, it might be necessary to install the software product again. Post-installation requisite consistency checks are also started by this flag. |
-V Number | Specifies the verbose option that provides four levels of
detail for preinstallation output. The valid values for the Number parameter
are 2, 3, or 4. The default level of verbosity, without the use of
the -V flag, prints an alphabetically ordered list of FAILURES, WARNINGS,
and SUCCESSES from preinstallation processing. Requisite failures
are reported with emphasis on the real cause of the failure. Extraneous
requisites for failed filesets are not displayed. The preinstallation
output is modified by levels 2 through 4 as described below:
Note: If verbosity level 2 or higher is used, the
files that are restored on to the system is shown in the output. Because
this will make installp's output much more verbose, make sure
that your / (root) file system does not become full when the
/smit.log becomes large (if using smit to run installp).
|
-w | Does not wildcard FilesetName. Use this flag from smit so it only installs the fileset chosen and not the filesets that match. For example, if you choose foo.rte, foo.rte.bar is not automatically pulled in, as it would be by default, without the -w flag. This flag applies only to AIX 4.2 or later. |
-X | Attempts to expand any file systems where there is insufficient space to do the installation. This option expands file systems based on current available space and size estimates that are provided by the software product package. Note that it is possible to exhaust available disk space during an installation even if the -X flag is specified, especially if other files are being created or expanded in the same file systems during an installation. Also note that any remote file systems cannot be expanded. |
-Y | Agrees to required software license agreements for software to be installed. This flag is only valid with the -a flag. |
-z BlockSize | Indicates in bytes the block size of the installation media. The default value of Size is 512. |
FilesetName | This is the name of the software product to be installed and can specify either an entire software product or any separately installable filesets within the software product. This can be used to specify the name of a fileset or fileset update. |
Level | This indicates the level of the software product or update that is to be installed and is of the form vv.rr.mmmm.ffff. If a fileset update has an additional fix ID (also know as ptf id), that ID must also be specified in the Level as in vv.rr.mmmm.ffff.ppppppp. |
Item | Description |
---|---|
0 (zero) | Indicates that all attempted installations were successful, or that no processing was required for the requested action on the requested filesets (for example, if a requested fileset was already installed). |
nonzero | Indicates that some part of the installation was not successful. |
A summary report is given at the end of the installp output that lists the status of each of the software products that were to be installed. For those software products that could not be installed or whose installation failed, the user can search for the cause in the more detailed information that is continually displayed from the installp command during the installation process.
Privilege Control: Only the root user can run this command.
Auditing Events:
Event | Information |
---|---|
INSTALLP_Inst | Success or failure of the apply, commit, reject, and cleanup operations. |
installp -L -d /dev/rmt0.1
installp -A -d /dev/rmt0.1 all
installp -aX -d/usr/sys/inst.images bos.net
installp -acF -d/dev/rmt0.1 bos.net.nfs.client 4.1.0.0
installp -a bos.net.tcp.client 4.1.0.2 bos.net.tcp.server 4.1.0.1
installp -u bos.net.tcp.server
mount Server_Name:/Save_Area /temp_space
installp -a -t /temp_space/My_Hostname \
bosnet.nfs.client 4.1.1.0
script
installp ...
<Ctrl>d
or installp ... 2>&1 | tee /tmp/inst.out
In
the second example, output is written to the screen and a copy is
saved. installp -pacgXd /dev/cd0 bos.net.tcp.client
A summary report is given at the end of the installp command output that lists the status of each of the software products that were to be installed. An example summary report for the previous installp command is as follows:
Installp Summary
----------------
Name Level Part Event Result
-----------------------------------------------------------------
bos.net.tcp.client 4.1.0.0 USR APPLY SUCCESS
bos.net.tcp.client 4.1.0.0 ROOT APPLY SUCCESS
bos.net.tcp.client 4.1.0.2 USR APPLY SUCCESS
installp -l -MR -d /usr/sys/inst.images
lslpp -lc | awk -F ":" '{print $2}' | tail -n +2 > /tmp/lslpp
installp -agXd /dev/cd0 -e /tmp/install.log -f /tmp/lslpp
where
the -e logs the output to the /tmp/install.log file.Item | Description |
---|---|
/dev/rfd0 | Specifies the default restore device. |
/dev/rmtn | Specifies the raw streaming tape interface. |
/usr/sys/inst.images directory | Contains files in backup format for use in installing or updating a complete set or subset of software products. |