pci_param_get_ioctl(9F) Kernel Functions for Drivers pci_param_get_ioctl(9F)NAMEpci_param_get_ioctl - extract the params for PF and VF drivers
SYNOPSIS
#include <sys/sunddi.h>
int pci_param_get_ioctl(dev_info_t *dip, intptr_t arg, int mode,
pci_param_t *php);
PARAMETERS
dip Pointer to dev_info structure.
arg, mode The device driver is expected to pass the arguments they
receive in their ioctl call directly to this interface.
php A pointer to a (void *) param handle.
DESCRIPTION
The pci_param_get_ioctl() function extracts the params from the arg
argument and returns a pci_param_t handle in php. Drivers should call
pci_param_free(9F) to free the param handle returned in this call after
retrieving params from the handle. Drivers are expected to use
pci_plist_get(9F) and pci_plist_getvf(9F) on the param handle to get
the name-value list for the PF and VF devices.
RETURN VALUES
DDI_SUCCESS A valid param handle pointer php is returned
Non-zero value The call failed to extract params from arg.
CONTEXT
The pci_param_get() function can be called from kernel non-interrupt
context.
ATTRIBUTES
See attributes(5) for descriptions of the following attributes:
┌─────────────────────────────┬─────────────────────────────┐
│ ATTRIBUTE TYPE │ ATTRIBUTE VALUE │
├─────────────────────────────┼─────────────────────────────┤
│Interface Stability │ Uncommitted │
└─────────────────────────────┴─────────────────────────────┘
SEE ALSOattributes(5), pci_param_free(9F), pci_param_get(9F),
pci_plist_get(9F), pci_plist_getvf(9F)SunOS 5.10 19 May 2011 pci_param_get_ioctl(9F)